I just built libvirt for the first time today, and noticed that configure fails on the first missing dependency, rather than trying harder to make it through and list all missing dependencies at the end. I ended up restarting configure multiple times. In the process, I also noticed that configure is somewhat out of date. So, what is the oldest version of autoconf and automake that libvirt will insist on supporting? For example, is it time to require automake 1.11.1 (the latest stable release) because of its security patch to avoid potential problems in 'make dist'? Or is it too soon to expect all distros to have an automake that new pre-installed, and more effort be put into supporting automake 1.9.6 and autoconf 2.59 (those being the implicit minimum requirements due to the use of gnulib)? Or somewhere in between? Meanwhile, how about this patch, for me getting my feet wet in helping to modernize the autotools usage, and hopefully leading up to future patches to make configure list all missing dependencies at once, rather than requiring multiple restarts.