[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/n] modernizing configure



On Sat, Jan 23, 2010 at 03:47:37PM -0700, Eric Blake wrote:
> I just built libvirt for the first time today, and noticed that
> configure fails on the first missing dependency, rather than trying
> harder to make it through and list all missing dependencies at the end.
> I ended up restarting configure multiple times.  In the process, I also
> noticed that configure is somewhat out of date.
> 
> So, what is the oldest version of autoconf and automake that libvirt
> will insist on supporting?  For example, is it time to require automake
> 1.11.1 (the latest stable release) because of its security patch to
> avoid potential problems in 'make dist'?  Or is it too soon to expect
> all distros to have an automake that new pre-installed, and more effort
> be put into supporting automake 1.9.6 and autoconf 2.59 (those being the
> implicit minimum requirements due to the use of gnulib)?  Or somewhere
> in between?

RHEL5 is the minimum required platform, including full bootstrap from 
GIT source. This implies automake-1.9.6-2.1 and autoconf-2.59-12

Daniel
-- 
|: Red Hat, Engineering, London   -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org  -o-  http://virt-manager.org  -o-  http://ovirt.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-  F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]