[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] libvirtError: internal error unknown boot device 'floppy'



Hello.    I believe I've found a bug in libvirtd but not sure.


Using libvirt-0.8.1 and virtinst-0.500.3 (and virt-manager-0.8.4 and Python 2.6.5 if relevant) on a linux system (kernel 2.6.35-rc4 if relevant)


I ran this virt-install command , which is trying to create a windows2k virt mc by importing an existing system consisting of a boot-floppy image on a file (the boot device) and one real disk device on /dev/sdc


virt-install --connect qemu:///system --name=RH7win2k --ram=392 --cpuset=0 --description="win2k on RH7 disk on usb, nat network" --import --network=network=default --virt-type=kqemu --accelerate --vnc --vncport=5905 --video=cirrus --disk=/mnt/soltbakp/commonfiles/win2k_boot.floppage,device=floppy --disk=/dev/sdc,device=disk --os-type=windows --os-variant=win2k


and it fails like so


ERROR internal error unknown boot device 'floppy'
ERROR internal error unknown boot device 'floppy'
Traceback (most recent call last):
File "/usr/local/bin/virt-install", line 1033, in <module>
main()
File "/usr/local/bin/virt-install", line 915, in main
start_time, guest.start_install)
File "/usr/local/bin/virt-install", line 957, in do_install
dom = install_func(conscb, progresscb, wait=(not wait))
File "/usr/local/lib/python2.6/site-packages/virtinst/Guest.py", line 972, in start_install
return self._do_install(consolecb, meter, removeOld, wait)
File "/usr/local/lib/python2.6/site-packages/virtinst/Guest.py", line 1037, in _do_install
"install")
File "/usr/local/lib/python2.6/site-packages/virtinst/Guest.py", line 1021, in _create_guest
self.domain = self.conn.defineXML(final_xml)
File "/usr/local/lib/python2.6/site-packages/libvirt.py", line 1224, in defineXML
if ret is None:raise libvirtError('virDomainDefineXML() failed', conn=self)
libvirtError: internal error unknown boot device 'floppy'


but if I repeat the command with just interchanging the order of the floppy and disk definitions,  (so that I am telling it to use the disk as boot device),  then the virt-install works ok as far as setup goes, but of course fails during boot  (and I can then alter the boot order back to what I should be in virt-manager and it then boots)


Is this a bug?   and if so is it already known?   (I couldn't find how to search the archives for this list and don't see it in google)




John Lumby




Enter for a chance to get your town photo on Bing.ca! Submit a Photo Now!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]