[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] libvirt on x64



I think I finally found such a system running RHEL 5.5 on x64 and it does have both a 32-bit and 64-bit version of libvirt installed (0.6.3).  Maybe this is just a SLES issue??

-----Original Message-----
From: Tavares, John 
Sent: Monday, July 26, 2010 2:01 PM
To: 'Eric Blake'
Cc: libvir-list redhat com; Tomen Tse; Chen, Jianjiun; Betley, Greg
Subject: RE: [libvirt] libvirt on x64

Hi Eric,

Thanks for getting back to me.  This may have been a system running SLES 10.2 (2.6.16.60-0.21-xen (SUSE Linux Enterprise Server 10 (x86_64))).

As to RHEL 5.5, it seems to come with 0.6.3 by default.  I am trying to find a system running a 64-bit kernel, but I have yet to find one in my environment.  Could you check to see if you have access to one to see if the same holds true as well??

My end goal is to have a single 32-bit application use libvirt on both x86 and x64.  I dislike having to ask customers to install another package on their system just for this.  I would think that both should be installed by default.

Thanks.

John

-----Original Message-----
From: Eric Blake [mailto:eblake redhat com] 
Sent: Monday, July 26, 2010 1:37 PM
To: Tavares, John
Cc: libvir-list redhat com; Tomen Tse; Chen, Jianjiun; Betley, Greg
Subject: Re: [libvirt] libvirt on x64

[sorry for the delayed reply]

On 07/12/2010 08:48 AM, Tavares, John wrote:
> I just logged onto the first X64 based machine with libvirt (0.3.3-18.5) installed on it and I am only seeing the X64 based version of the shared library.  Here is what I am seeing:

Which distro?  Also, libvirt 0.3.3 is rather old; we are now at 0.8.2
upstream, and Fedora 13 includes 0.7.7.

> 
> $ rpm -qal libvirt | grep libvirt.so
> /usr/lib64/libvirt.so.0
> /usr/lib64/libvirt.so.0.3.3
> 
> Is there any reason why the 32-bit version is not also installed??  My application is 32-bit based, so it will not work on this hardware because of this.

Generally, on an x86_64 platform that uses rpms, the 32-bit libraries
are available as a separate rpm.  For example, I'm running Fedora 13 on
an x86_64 host; so I would use 'yum install libvirt-devel.i686' to get
the 32-bit development libraries.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]