[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [Qemu-devel] [PATCH] Introduce a -libvirt-caps flag as a stop-gap



On (Tue) Jul 27 2010 [10:55:03], Anthony Liguori wrote:
> +            case QEMU_OPTION_libvirt_caps:
> +                printf("version: " QEMU_VERSION "\n"
> +                       "package: " QEMU_PKGVERSION "\n"
> +                       "caps: name,enable-kvm,no-reboot,uuid,xen-domid,drive"
> +                       ",cache-v2,format,vga,serial,mem-path,chardev,balloon"
> +                       ",device,rtc,netdev,sdl,topology\n");
> +                exit(0);
> +                break;

This can't work; people have to remember not only to update
documentation but also this case here to ensure libvirt works fine.

There are some other options that might work:
- making such a list by taking the savevm section name and version
  number for each device
- The parameters supported by devices registered with qdev (and their
  defaults)
- etc.

But basically this means libvirt will have to do more work now and also
add support for capabilities later. We can instead just keep 0.13 as it
is and move to capabilities for 0.14.

		Amit


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]