[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Xen 4.0 and DPCI key in sexpr



Matthias Bolte wrote:
This blog post [1] explains how to apply some OpenSuse patches [2]
(especially xen-domctl-ver7.patch)

Ah yes, reminds me to upstream this patch. We had all of the cpu pools patches (which changed domctl interface) in Xen4.0 in openSUSE build service. These patches were not included in official Xen4.0 release but have since been included in xen-unstable. In order to use the Xen in OBS, I needed to patch libvirt to handle domctl version 7. Now that the cpu pools patches have been taken in xen-unstable it's time to upstream the libvirt patch as well.

 to the libvirt 0.8.1 Debian package
in order to get Xen 4.0 support.

Xen4.0 doesn't contain the cpu pools feature, which changes the domctl interface. I guess they are using xen-unstable, or perhaps have Fujitsu's cpu pools patches as well?

Thanks,
Jim


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]