[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Fwd: Re: [virt-tools-list] Lilo succeeds with kvm but not virt-manager



Forwarding to libvir-list ...

Rich.

----- Forwarded message from Daniel Janzon <daniel janzon edgeware tv> -----

Subject: Re: [virt-tools-list] Lilo succeeds with kvm but not virt-manager
Date: Mon, 07 Jun 2010 10:56:29 +0200
From: Daniel Janzon <>
To: virt-tools-list

On 06/05/2010 06:00 PM, virt-tools-list-request redhat com wrote:
> Message: 1
> Date: Fri, 4 Jun 2010 17:55:17 +0100
> From: "Richard W.M. Jones"<rjones redhat com>
> To: Daniel Janzon<daniel janzon edgeware tv>
> Cc: virt-tools-list redhat com
> Subject: Re: [virt-tools-list] Lilo bootloader succeeds with kvm but
> 	not	virt-manager
> Message-ID:<20100604165517 GA4612 amd home annexia org>
> Content-Type: text/plain; charset=us-ascii
>
> On Fri, Jun 04, 2010 at 02:03:12PM +0200, Daniel Janzon wrote:
>    
>> I installed Linux Suse as a guest in virt-manager/KVM and had trouble to
>> install grub. So I used good old Lilo instead. When running Suse in
>> virt-manager Lilo fails with
>>
>>    LILO - Keytable read/checksum error on bootup
>>
>> When I go
>>
>>    kvm -m 512 -hda SLES-10.3.img
>>      
> libvirt won't have such a simple command line.  There could be other
> KVM options which affect things at boot.
>
> I have a couple of suggestions:
>
> (1) Find out the full libvirt command line.  Easiest is to start the
> domain under virt-manager and quickly use the 'ps ax' command.  (There
> is a more "official" way to convert libvirt XML into a qemu command
> line but I cannot recall what that is at the moment).
>    

Smart! I did that and found out that it is the boot=on drive option that  
is the cause of the problem:

    -drive file=/root/SLES-10.3.img,if=ide,index=0,boot=on

For some reason it only works when it is set to boot=off. I tried  
<boot>off</boot> and boot="off" in the target tag in the corresponding  
disk tag in the XML file, but with no luck. I also tried to remove the  
<boot dev='hd'/> from the os tag. I did do a "/etc/init.d/libvirt-bin  
reload" just in case. Is there any way to get control the boot option from 
the XML file?

> (2) Use virt-rescue or guestfish and see if you can install grub in
> the domain.  In guestfish it'd be something like this:
>
>    guestfish -i GuestName
>    ><fs>  mkdir-p /boot/grub
>    ><fs>  grub-install /boot /dev/sda1
>
> (You might need to change those command slightly and read the man page
> for virt-rescue, guestfish and/or grub-install).
>    

Ok, thanks for the tip. I will consider it if it impossible to control the 
boot option as explained above. Or maybe I'll just settle with being  
annoyed and start the machine from the command line :)


All the best,
Daniel Janzon

_______________________________________________
virt-tools-list mailing list
virt-tools-list redhat com
https://www.redhat.com/mailman/listinfo/virt-tools-list

----- End forwarded message -----

-- 
Richard Jones, Virtualization Group, Red Hat http://people.redhat.com/~rjones
libguestfs lets you edit virtual machines.  Supports shell scripting,
bindings from many languages.  http://et.redhat.com/~rjones/libguestfs/
See what it can do: http://et.redhat.com/~rjones/libguestfs/recipes.html


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]