[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Improve some error messages about unsupported APIs/URIs



On 06/22/2010 11:40 AM, Daniel P. Berrange wrote:
> If there is no driver for a URI we report
> 
>   "no hypervisor driver available"
> 
> This is bad because not all virt drivers are hypervisors (ie container
> based virt).
> 
> If there is no driver support for an API we report
> 
>   "this function is not supported by the hypervisor"
> 
> This is bad for the same reason, and additionally because it is
> also used for the network, interface & storage drivers.

ACK.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]