[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Segfault in virDomainObjListSearchName when listing domains (qemu backend)



On Fri, Jun 25, 2010 at 06:08:07PM +0200, Guido Winkelmann wrote:
> This is the guest's XML config:
> =====================
> <domain type='kvm'>
>   <name>testserver-a</name>
>   <uuid>ce57ebe0-ea37-0353-bbe0-e23dbbd17708</uuid>
>   <description>libvirt C-API Test</description>
>   <memory>262144</memory>
>   <currentMemory>262144</currentMemory>
>   <vcpu>1</vcpu>
>   <os>
>     <type arch='x86_64' machine='pc-0.13'>hvm</type>
>     <boot dev='hd'/>

[snip]

> =====================
> 
> (as found in /usr/local/etc/libvirt/qemu/)
> 
> and here are the last few lines from the logfile 
> (/usr/local/var/log/libvirt/qemu/testserver-a.log):

Have you set any LIBVIRT_LOG environment variables or set any of
the logging settings in /etc/libvirt/libvirtd.conf ? If so, which
ones ?  Your log file contains alot of stuff I wouldn't normally
expect to be there & I wonder if there is a verbose logging level
enabled that is causing a buffer overflow somewhre ?

> 
> =====================
> LC_ALL=C 
> PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin 
> HOME=/root USER=root LOGNAME=root QEMU_AUDIO_DRV=none /usr/bin/qemu-kvm -S -M 
> pc-0.13 -enable-kvm -m 256 -smp 1,sockets=1,cores=1,threads=1 -name 
> testserver-a -uuid ce57ebe0-ea37-0353-bbe0-e23dbbd17708 -nodefaults -chardev 
> socket,id=monitor,path=/usr/local/var/lib/libvirt/qemu/testserver-
> a.monitor,server,nowait -mon chardev=monitor,mode=readline -rtc base=utc -no-
> acpi -boot c -device lsi,id=scsi0,bus=pci.0,addr=0x7 -drive 
> file=/data/testserver-a-system.img,if=none,id=drive-scsi0-0-1,boot=on -device 
> scsi-disk,bus=scsi0.0,scsi-id=1,drive=drive-scsi0-0-1,id=scsi0-0-1 -drive 
> file=/data/testserver-a-data1.img,if=none,id=drive-virtio-disk1 -device 
> virtio-blk-pci,bus=pci.0,addr=0x4,drive=drive-virtio-disk1,id=virtio-disk1 -
> drive file=/data/testserver-a-data2.img,if=none,id=drive-virtio-disk2 -device 
> virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk2,id=virtio-disk2 -
> drive file=/data/gentoo-install-amd64-
> minimal-20100408.iso,if=none,media=cdrom,id=drive-ide0-0-0,readonly=on -device 
> ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive 
> file=/data/testserver-a_configfloppy.img,if=none,id=drive-fdc0-0-0 -global 
> isa-fdc.driveA=drive-fdc0-0-0 -device 
> e1000,vlan=0,id=net0,mac=52:54:00:84:6d:69,bus=pci.0,addr=0x6 -net 
> tap,fd=22,vlan=0,name=hostnet0 -usb -vnc 127.0.0.1:1,password -k de -vga 
> cirrus -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x3
> 17:21:14.760: debug : virCgroupNew:542 : New group /libvirt/qemu/testserver-a
> 17:21:14.760: debug : virCgroupDetect:232 : Detected mount/mapping 0:cpu at 
> /mnt/cgroups/cpu in /sysdefault
> 17:21:14.760: debug : virCgroupDetect:232 : Detected mount/mapping 1:cpuacct 
> at /mnt/cgroups/cpuacct in /sysdefault
> 17:21:14.760: debug : virCgroupDetect:232 : Detected mount/mapping 3:memory at 
> /mnt/cgroups/memory in /sysdefault
> 17:21:14.760: debug : virCgroupDetect:232 : Detected mount/mapping 4:devices 
> at /mnt/cgroups/devices in /sysdefault
> 17:21:14.760: debug : virCgroupMakeGroup:484 : Make group 
> /libvirt/qemu/testserver-a
> 17:21:14.760: debug : virCgroupMakeGroup:496 : Make controller 
> /mnt/cgroups/cpu/sysdefault/libvirt/qemu/testserver-a/
> 17:21:14.760: debug : virCgroupMakeGroup:496 : Make controller 
> /mnt/cgroups/cpuacct/sysdefault/libvirt/qemu/testserver-a/
> 17:21:14.760: debug : virCgroupMakeGroup:496 : Make controller 
> /mnt/cgroups/memory/sysdefault/libvirt/qemu/testserver-a/
> 17:21:14.760: debug : virCgroupMakeGroup:496 : Make controller 
> /mnt/cgroups/devices/sysdefault/libvirt/qemu/testserver-a/
> 17:21:14.760: debug : virCgroupSetValueStr:277 : Set value 
> '/mnt/cgroups/cpu/sysdefault/libvirt/qemu/testserver-a/tasks' to '1761'
> 17:21:14.770: debug : virCgroupSetValueStr:277 : Set value 
> '/mnt/cgroups/cpuacct/sysdefault/libvirt/qemu/testserver-a/tasks' to '1761'
> 17:21:14.778: debug : virCgroupSetValueStr:277 : Set value 
> '/mnt/cgroups/memory/sysdefault/libvirt/qemu/testserver-a/tasks' to '1761'
> 17:21:14.789: debug : virCgroupSetValueStr:277 : Set value 
> '/mnt/cgroups/devices/sysdefault/libvirt/qemu/testserver-a/tasks' to '1761'
> 17:21:14.802: debug : qemudInitCpuAffinity:2227 : Setting CPU affinity
> 17:21:14.803: debug : qemuSecurityDACSetProcessLabel:546 : Dropping privileges 
> of VM to 0:0
> Supported machines are:
> pc         Standard PC (alias of pc-0.12)
> pc-0.12    Standard PC (default)
> pc-0.11    Standard PC, qemu 0.11
> pc-0.10    Standard PC, qemu 0.10
> isapc      ISA-only PC

This is the ultimate problem - your guest XML lists 'pc-0.13', so I assume
you must have deployed this guest with a newer QEMU and now trying to start
it with an older one. Changing the XML to list one of these valid machine
types should let you start the guest


Daniel
-- 
|: Red Hat, Engineering, London    -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org -o- http://virt-manager.org -o- http://deltacloud.org :|
|: http://autobuild.org        -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]