[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Update on PHP libvirt



Dne 29.6.2010 17:38, Eric Blake napsal(a):
On 06/29/2010 09:27 AM, David W King wrote:
I'm running Ubuntu 10.04 with php 5.3.2.  In order to get the extension
to compile I had to apply the attached patch.

Could you please resend that patch as a context diff?  ed script diffs
are practically impossible to apply correctly if anything else has
touched the file.

Our hacking instructions give more hints on how to generate a worthwhile
patch:
http://libvirt.org/git/?p=libvirt.git;a=blob;f=HACKING

Also, it would help to paste the actual compiler error that you are
trying to address with your patch.

I did encounter this bug already. Its related to certain PHP version and the compile error is almost self-explaining (the thing almost unbelievable with gcc :-) )
php-libvirt-0.3-alpha/libvirt.c:19: error: duplicate static
php-libvirt-0.3-alpha/libvirt.c: In function zm_startup_libvirt
I have seen other PHP extensions with this problem. The documentation for writing PHP extensions is not very good and a lot of things are done by macros. So I am guessing that the PHP developers did add the static keyword to the macro...

I updated the webpage and I put the version with this correction there.

Radek

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]