[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] debugging daemon-conf failure



Eric Blake wrote:
> ----- "Jim Meyering" <jim meyering net> wrote:
>> Eric Blake wrote:
>> > Ever since I first started playing with libvirt last month, 'make
>> check'
>> > has been failing for me on the same test:
>> >
>> > $ VIR_TEST_DEBUG=2 make -C tests check TESTS=daemon-conf
>>
>> What type of system are you using?
>
> This is on a machine that is 4 years old, running F12.
> $ uname -a
> Linux eblake 2.6.31.12-174.2.22.fc12.i686 #1 SMP Fri Feb 19 19:26:06 UTC 2010 i686 i686 i386 GNU/Linux
>
>> Parts of that test are a little obscure-looking (you can probably
>> blame
>> me for that).  It starts with the sample config file and iterates
>> through it corrupting one line at a time.  If running libvirtd with
>> each resulting corrupted config file does not yield the expected
>> result,
>> its a failure.
>>
>> A good place to start would be to save one of the failing config
>> files and to invoke libvirtd manually to see exactly what it's
>> printing and thus get a hint as to why the expected diagnostic is
>> missing.
>
> Or even trying to run successfully.  I created the following tmp.conf:
>
> listen_tls = 0
> listen_tcp = 1
...
>
> then ran:
>
> $ daemon/libvirtd --pid-file=pid-file --config=tmp.conf
> 16:17:16.754: error : remoteConfigGetAuth:2564 : remoteReadConfigFile: tmp.conf: auth_tcp: unsupported auth sasl
>
> Ideas of what to do next?  Maybe the test should be reordered
> to first attempt testing an unmodified conf file, and only if
> that succeeds, then rip through the list of one-per-line corruptions?
> Am I missing some setup or packages to get SASL support enabled?

I'll bet you're right.  Note this one on the list below:

    cyrus-sasl-devel

Here's the list of packages you'll want to install before configuring.

  $ grep '^BuildRe' libvirt.spec
  BuildRequires: python-devel
  BuildRequires: util-linux
  BuildRequires: nfs-utils
  BuildRequires: xen-devel
  BuildRequires: xmlrpc-c-devel >= 1.14.0
  BuildRequires: libxml2-devel
  BuildRequires: xhtml1-dtds
  BuildRequires: readline-devel
  BuildRequires: ncurses-devel
  BuildRequires: gettext
  BuildRequires: gnutls-devel
  BuildRequires: hal-devel
  BuildRequires: libudev-devel >= 145
  BuildRequires: libpciaccess-devel >= 0.10.9
  BuildRequires: yajl-devel
  BuildRequires: avahi-devel
  BuildRequires: libselinux-devel
  BuildRequires: dnsmasq
  BuildRequires: bridge-utils
  BuildRequires: cyrus-sasl-devel
  BuildRequires: polkit >= 0.93
  BuildRequires: PolicyKit-devel >= 0.6
  BuildRequires: util-linux
  BuildRequires: /usr/bin/qemu-img
  BuildRequires: /usr/sbin/qcow-create
  BuildRequires: lvm2
  BuildRequires: iscsi-initiator-utils
  BuildRequires: parted-devel
  BuildRequires: e2fsprogs-devel
  BuildRequires: device-mapper
  BuildRequires: device-mapper-devel
  BuildRequires: numactl-devel
  BuildRequires: libcap-ng-devel >= 0.5.0
  BuildRequires: libssh2-devel
  BuildRequires: netcf-devel >= 0.1.4
  BuildRequires: gawk

It'd be nice if "make check" would fail right away with an explanation
(overridable if you promise not to file bugs about resulting test failures ;-)
when libvirt has been built without certain essential-for-proper-testing
packages.

Or maybe a library analog of the existing bootstrap-time check for
minimal program version requirements:

    # Build prerequisites
    buildreq="\
    autoconf   2.59
    automake   1.9.6
    autopoint  -
    gettext    -
    git        1.5.5
    gzip       -
    libtool    -
    perl       5.5
    rsync      -
    tar        -
    "


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]