[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] do not require two ./autogen.sh runs to permit "make"



Daniel P. Berrange wrote:
> On Tue, Mar 16, 2010 at 09:42:32PM +0100, Jim Meyering wrote:
>> I tracked down the source of the two-autogen.sh-runs-required bug.
>> Here's the fix:
>>
>> Subject: [PATCH] do not require two ./autogen.sh runs to permit "make"
>>
>> * autogen.sh (bootstrap_hash): New function.
>> Running bootstrap may update the gnulib SHA1, yet we were computing
>> t=$(git submodule status ...) *prior* to running bootstrap, and
>> then recording that sometimes-stale value in the stamp file upon
>> a successful bootstrap run.  That would require two (lengthy!)
>> bootstrap runs to update the stamp file.
...[40 lines elided]...
>
> ACK

Thanks.
Pushed.

Just a good-natured reminder: everyone I know prefers review feedback
that removes quoted context for which there is no new comment.  Even here,
where the patch was small and easy to "see", omitting the 40-50 lines after
the embedded Subject: or log would have made it a tiny bit easier to read.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]