[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Fix pthread related link error for virt-aa-helper



Matthias Bolte wrote:
> 2010/5/7 Jim Meyering <jim meyering net>:
>> Matthias Bolte wrote:
>>> Link virt-aa-helper explicitly with pthread. This is at least
>>> required on Ubuntu 10.04.
>>
>> Hi Matthias,
>>
>> If the link failure was due solely to virt-aa-helper's use of
>> the util library, then this patch may have solved that problem
>> at the source:
>>
>>    avoid link error in tests using libvirt_util; due to pthread_sigmask
>>    http://libvirt.org/git/?p=libvirt.git;a=commitdiff;h=0e9b3a269be9ce8
>>
>> If so, please revert this patch.
>
> I noticed this problem after updating to current git head with your
> patch already included, so my patch is necessary.

Merely changing library options in the src/Makefile.am does not
cause all libraries to be recreated, so it is likely that you are
still using a util library created without -lpthread, and thus
you would not have seen any benefit to my patch.

You can confirm that it is not required by running e.g.,

  touch src/util/util.c && make

without your patch.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]