[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: avoid compile failure on linux kernels older than 2.6.19



On 05/17/2010 10:25 AM, Jim Meyering wrote:
> This is required for any kernel prior to 2.6.19,
> since <linux/magic.h> didn't exist back then.
> Now that file is provided by the kernel-headers package.
> 
>>From d14ef1669968ffeb65076b007e318934ed99aa61 Mon Sep 17 00:00:00 2001
> From: Jim Meyering <meyering redhat com>
> Date: Mon, 17 May 2010 16:17:08 +0200
> Subject: [PATCH] build: avoid compile failure on linux kernels older than 2.6.19
> 
> * configure.ac: Check for <linux/magic.h>.
> * src/util/storage_file.c: Include <linux/magic.h> only if present.
> Linux kernels prior to 2.6.19 lacked it.
> [__linux__] (NFS_SUPER_MAGIC): Define if not already defined.

Yeah, this caused compile failure over the weekend for me.  There's
a similar #define in the qemu_driver.c sources; we should think about
combining these at some point, but this fixes the immediate problem.

ACK

-- 
Chris Lalancette


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]