[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] how to attach PCI/USB device



On 11/01/2010 08:50 PM, Zdenek Styblik wrote:
> On 11/01/10 20:18, Diego Elio Pettenò wrote:
>> Il giorno lun, 01/11/2010 alle 19.45 +0100, Zdenek Styblik ha scritto:
>>> I'm using virt-managers to add/attach devices. I've failed to attach
>>> PCI
>>> device, but it "does not" matter right now. I can attach USB devices,
>>> but they are not in VM. I've tried to attach USB HUB as well and what
>>> not - nothing. 
>>
>> I'd suggest you to try with the current git head. I had had some trouble
>> with this the past week or so:
>>
> 
> Ok, I'm going to try it tomorrow.
> 
>>  - 0.8.5 release will not allow access to the device if cgroups are
>> enabled.
>>
> 
> I've commented cgroups out in qemu.conf and - it didn't help. :|
> 
>> Not sure about the PCI stuff sincerely, but at least USB with the
>> current git head works fine for me (finally).
>>
> 
> Zdenek
> 

Well, tested with your patch and - it works only half-way, or I'm doing
something wrong(I'm sure I do, but I don't know what).
I can see device(s) in % lsusb; in guest, however eg. USB flash disk can
be seen, but - that's all. Like it doesn't exist. It's just not there.
I've tried to comment in/out cgroups and it doesn't matter.

What I'm getting is:
"usb X: reset full speed USB device using uhci_hcd and address Y"

That can't be good :)

Damn, this is harder than I thought.

Thanks,
Zdenek

-- 
Zdenek Styblik
Net/Linux admin
OS TurnovFree.net
email: stybla turnovfree net
jabber: stybla jabber turnovfree net


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]