[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] how to attach PCI/USB device



On Mon, Nov 01, 2010 at 08:18:30PM +0100, Diego Elio Pettenò wrote:
> Il giorno lun, 01/11/2010 alle 19.45 +0100, Zdenek Styblik ha scritto:
> > I'm using virt-managers to add/attach devices. I've failed to attach
> > PCI
> > device, but it "does not" matter right now. I can attach USB devices,
> > but they are not in VM. I've tried to attach USB HUB as well and what
> > not - nothing. 
> 
> I'd suggest you to try with the current git head. I had had some trouble
> with this the past week or so:
> 
>  - 0.8.4 has a bug when the bus/device pair has a number > 8 (it's
> loaded as octal by qemu, but passed as decimal by libvirt);
>  - 0.8.5 release will not allow access to the device if cgroups are
> enabled.
> 
> Not sure about the PCI stuff sincerely, but at least USB with the
> current git head works fine for me (finally).

Except for the caveat that there are huge numbers of USB devices that simply
don't work with QEMU at all, due to limitations of QEMU's  USB support

Daniel.
-- 
|: Red Hat, Engineering, London    -o-   http://people.redhat.com/berrange/ :|
|: http://libvirt.org -o- http://virt-manager.org -o- http://deltacloud.org :|
|: http://autobuild.org        -o-         http://search.cpan.org/~danberr/ :|
|: GnuPG: 7D3B9505  -o-   F3C9 553F A1DA 4AC2 5648 23C1 B3DF F742 7D3B 9505 :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]