[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Rename 'remove' param to 'toremove' to avoid clash with Win32 header



On 11/23/2010 06:33 AM, Daniel P. Berrange wrote:
> The win32 headers have a function called 'remove' declared. This
> clashes with the 'remove' parameter in virShrinkN

Not just win32, but all <stdio.h> implementations.

> 
> * src/util/memory.c: Rename 'remove' to 'toremove'
> ---
>  src/util/memory.c |   12 ++++++------
>  1 files changed, 6 insertions(+), 6 deletions(-)

ACK.  Wonder why -Wshadow didn't catch that for me?

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]