[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Mac OS X: dyld: lazy symbol binding failed



All,

With a few small patches (to remove documentation generation, thanks
to Justin) to my local git checkout, I was finally able to "make dist"
and test the resulting distribution. The result is that this worked
great on my Mac as well as another Mac I have that was having trouble.
I think this strongly supports the argument that the issue is that the
libvirt build server autotools versions are out of date which is
causing an issue for some reason on Mac. My autotools versions follow,
for reference:

Autoconf: 2.68
Automake: 1.11.1
Libtool: 2.4

For reference, or if anyone has a Mac and wants to try, I've uploaded
my distribution here:
http://mitchellh.github.com/libvirt/libvirt-0.8.4.tar.gz

Is this enough evidence in favor of build tool versions? Would anyone
like me to try anything else?

Thanks,
Mitchell

On Thu, Oct 14, 2010 at 1:28 PM, Mitchell Hashimoto
<mitchell hashimoto gmail com> wrote:
> Eric,
>
> First, here is the output from diff -c:
> https://gist.github.com/7d8c32849e4d72be5368
>
> I ran `automake --version` and I have "1.11.1" And the "1.9.6"
> automake is from the libvirt build servers, not any of my machines. I
> was comparing the "./configure" output from the snapshot with when I
> run "autogen.sh" myself.
>
> I'm not sure about the other points you brought up. I just ran the
> typical commands that README-hacking says to.
>
> Mitchell
>
> On Thu, Oct 14, 2010 at 12:44 PM, Eric Blake <eblake redhat com> wrote:
>> On 10/14/2010 01:06 PM, Mitchell Hashimoto wrote:
>>>
>>> Daniel,
>>>
>>> Thanks for your response, I appreciate it. The `grep` on the two
>>> Makefiles is equivalent. I've uploaded a diff of the two Makefiles
>>> here: https://gist.github.com/da0e93a335be6a3a637b Let me know if you
>>> want me to upload the actual Makefiles as well, since I can do that.
>>
>> Can you provide a context diff (diff -u or diff -c) rather than an ed-script
>> diff?  Context can be essential in a review.
>>
>> At any rate:
>>
>> < # Makefile.in generated by automake 1.9.6 from Makefile.am.
>> ---
>>> # Makefile.in generated by automake 1.11.1 from Makefile.am.
>>
>> Is this stock automake 1.9.6, or does it have a distro patch to fix
>> CVE-2009-4029?  Using an older automake may be the root cause of remaining
>> problems, if we are relying on a feature that only automake 1.10 or 1.11
>> provides.
>>
>> What is 'automake --version' for you, and did you generate the tarballs, or
>> is the automake 1.9.6 on someone else's machine?
>>
>> < $(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
>> < $(top_srcdir)/m4/progtest.m4 $(top_srcdir)/m4/size_max.m4 \
>> < $(top_srcdir)/m4/wchar_t.m4 $(top_srcdir)/m4/wint_t.m4 \
>> < $(top_srcdir)/m4/xsize.m4 $(top_srcdir)/acinclude.m4 \
>> < $(top_srcdir)/configure.ac
>> ---
>>> $(top_srcdir)/m4/libtool.m4 $(top_srcdir)/m4/ltoptions.m4 \
>>> $(top_srcdir)/m4/ltsugar.m4 $(top_srcdir)/m4/ltversion.m4 \
>>> $(top_srcdir)/m4/lt~obsolete.m4 $(top_srcdir)/m4/nls.m4 \
>>> $(top_srcdir)/m4/po.m4 $(top_srcdir)/m4/progtest.m4 \
>>> $(top_srcdir)/m4/size_max.m4 $(top_srcdir)/m4/wchar_t.m4 \
>>> $(top_srcdir)/m4/wint_t.m4 $(top_srcdir)/m4/xsize.m4 \
>>> $(top_srcdir)/acinclude.m4 $(top_srcdir)/configure.ac
>>
>> Why the difference in which libtool .m4 files are provided?
>>
>> < configure.lineno configure.status.lineno
>> ---
>>> configure.lineno config.status.lineno
>>
>> There's no such file as configure.status.lineno; but that's attributable to
>> a bug in the older automake that has since been fixed.
>>
>> I've stopped looking at this point.
>>
>> --
>> Eric Blake   eblake redhat com    +1-801-349-2682
>> Libvirt virtualization library http://libvirt.org
>>
>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]