[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] qemu: Don't fail driver startup with ancient qemu



On Mon, Apr 04, 2011 at 14:23:59 +0100, Daniel P. Berrange wrote:
> On Mon, Apr 04, 2011 at 03:18:59PM +0200, Jiri Denemark wrote:
> > Failure to extract version info (e.g., because qemu binary is so ancient
> > that it doesn't even support -help) shouldn't be considered fatal since
> > we only need it to detect whether qemu supports bootindex option.
> > ---
> >  src/qemu/qemu_capabilities.c |    7 ++++---
> >  1 files changed, 4 insertions(+), 3 deletions(-)
> 
> What version QEMU doesn't support -help ?
> 
> We only aim to work with QEMU >= 0.9.0 and I'm fairly sure
> that has -help support.

An ancient one, 0.6.0. But that was just an example. Extracting version info
may fail for a bunch of reasons. The main thing is that it shouldn't fail qemu
driver startup since that results in libvirtd startup failure.

Jirka


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]