[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Using Restore in another host.



Hello
I'm thinking to upgrade the libvirt to solve the problem as you said in your last mail.
But I've installed the package using "apt-get install" and I can''t get higher version of all the packages involves doing an upgrade in ubuntu (I'm using 10.04)
Can you suggest-me "an easy" way to upgrate the libvirt? 
Thank you very much.
Marcela



2011/4/6 Eric Blake <eblake redhat com>
On 04/06/2011 04:09 AM, Michal Novotny wrote:
> Hi,
> the interesting thing is the "Permission denied" message in the log file:
>
> LC_ALL=C
> PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/bin
> QEMU_AUDIO_DRV=none /usr/bin/qemu-system-x86_64 -S -M pc-0.12
> -enable-kvm -m 4096 -smp 4 -name chompi1 -uuid
> 22f013aa-25d4-b317-9eac-b232692db8c7 -chardev
> socket,id=monitor,path=/var/lib/libvirt/qemu/chompi1.monitor,server,nowait
> -monitor chardev:monitor -boot c -drive
> file=/home/radic/mvdata/imagenes/chompi1.img,if=ide,index=0,boot=on,format=raw
> -drive if=ide,media=cdrom,index=2,format=raw -net
> nic,macaddr=52:54:00:82:ce:80,vlan=0,model=virtio,name=virtio.0 -net
> tap,fd=34,vlan=0,name=tap.0 -chardev pty,id=serial0 -serial
> chardev:serial0 -parallel none -usb -vnc 0.0.0.0:0 -vga cirrus -incoming
> exec:cat
> char device redirected to /dev/pts/2
> cat: -: Permission denied <== THIS ONE
> load of migration failed
>
> I don't know much about the internal libvirt design since libvirt is not
> my primary space so I hope my e-mails from yesterday helped a little but
> I'll leave the rest for libvirt guys since I'm not having any other
> ideas what could be wrong there.

That's a weird error - cat is complaining that it can't read stdin,
which is usually a symptom associated with SELinux permissions.  But you
said earlier in this thread that you aren't using SELinux.  Are you
using AppArmor?

At any rate, does upgrading to libvirt 0.9.0 improve the situation?
exec: migration has always been risky (there are various data races
involved in coordinating multiple processes, where qemu is using popen()
to manage the use or even opening the file), and so newer libvirt uses
fd: migration (where the fd is already open, so we don't even have to
worry about permissions from qemu's point of view).

--
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]