[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [virt-tools-list] libvirt spice command line appears to be incorrect

On Tue, Apr 26, 2011 at 2:05 AM, Eric Blake <eblake redhat com> wrote:
On 04/25/2011 03:54 PM, Emre Erenoglu wrote:
> yes, libvirt 0.8.7 was silently reverting the change I made manually in the
> xml file. Neither virsh edit nor editing the xml and re-defining it worked.
> Once libvirt saw the "spicevmc" there, it just removed it and put "null"
> instead.

There has been some upstream work to make libvirt do better at detecting
bogus configurations, but I'm not sure off the top of my head if it
includes the instance you tripped over.  So, the question remains
whether we have already fixed the bug in 0.9.0, or whether, if you put
in some other random string in place of "spicevmc", then would libvirt
still silently change that to "null" instead of rejecting the XML.  If
the former, great - we've cleaned it up!  If the latter, then this is a
bug still in libvirt worth fixing.

I re-installed 0.8.7. It re-wrote the existing virtual machine channel device definition (which used to be "spicevmc" with 0.9.0) back to 'null'.

I tried to edit it by hand, with any string, always reverted to 'null'.

In libvirt 0.9.0, editing by hand to replace 'null' with 'spicevmc' works. Editing by hand to an arbitrary string, fails with the following error message (when I put 'emre' instead of 'null'):

error: XML description for unknown type presented to host for character device: emre is not well formed or invalid

So looks like it's fixed in 0.9.0 but I let you conclude the 0.8.7 behaviour.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]