[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] build: Fix problem of building Python bindings



If one specify "--with-python=yes" but no python-devel package
is installed, we ignore it with just a notice message, which
doesn't give clear guide to user.
---
 configure.ac |    6 ++----
 1 files changed, 2 insertions(+), 4 deletions(-)

diff --git a/configure.ac b/configure.ac
index 190bf40..758c893 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1917,15 +1917,13 @@ if test "$with_python" != "no" ; then
                         then
                             PYTHON_INCLUDES=-I/usr/include/python$PYTHON_VERSION
                         else
-                            AC_MSG_NOTICE([Could not find python$PYTHON_VERSION/Python.h, disabling bindings])
-                            with_python=no
+                            AC_MSG_ERROR([You must install python-devel to build Python bindings])
                         fi
                     fi
                 fi
             fi
         else
-            AC_MSG_NOTICE([Could not find python interpreter, disabling bindings])
-            with_python=no
+            AC_MSG_ERROR([You must install python to build Python bindings])
         fi
     else
         AC_MSG_NOTICE([Could not find python in $with_python, disabling bindings])
-- 
1.7.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]