[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Availability of 0.9.4 candidate release 2 rc1



On 08/01/2011 02:08 AM, Matthias Bolte wrote:
> 
> The invalid reads by __strspn_sse42 and __strspn_sse42 are actually
> bugs in glibc where it uses optimized code on too short strings.

Not so much bugs in glibc (as long as the short reads do not cross page
boundaries, and glibc does not use the unitialized data for making any
decisions, then it is fair game), as a discrepancy between valgrind
exemption rules and the latest glibc.  That is, the bug is in valgrind
for not exempting that glibc pattern out of the box.

> Nothing we could fix from the libvirt side.

Well, libvirt could add an exemption pattern for that particular glibc
usage, rather than waiting for valgrind and/or glibc to sync up to one
another again.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]