[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Re: libvirt-0.9.1 to 0.9.3-r1: managedsave/save won't start/restore at saved state



The 05/08/11, Laine Stump wrote:

> >So, I've tried yet another thing. I made a tarball of the whole working
> >system and installed it on the testing bare metal (Core i3-2100).
> >
> >The 'start' command after 'managedsave' still fails. Then, I tried to
> >change kvm related kernel compilation option and compiled kvm-intel as
> >module: fails again.
> >
> >Did the hardware requirements change for libvirt/qemu-kvm? I can't
> >understand why the _exact same_ system works on a hardware and not on
> >another (where previously it worked perfectly well).
> 
> One likely possibility is some sort of race condition where CPU
> speed (and other hardware related) differences) cause one
> thread/process to win the race on one of the machines, and another
> process/thread to win on the other (the test I suggested earlier was
> inspired by just such a race that I previously encountered, but
> apparently the qemu you're running already has the fix for that one
> :-( )

Hmm. I wonder if this is so simple. I tried yet on another CPU and where
it fails, too.

So, the system was tested on:
- Intel(R) Core(TM) i3 CPU 540  @ 3.07GHz (fail)
- Intel(R) Xeon(R) CPU E5310  @ 1.60GHz (fail)
- Intel(R) Core(TM) i3-2100 CPU @ 3.10GHz (fail)
- Intel(R) Xeon(R) CPU E5420  @ 2.50GHz (work)

The only difference I can find is that on all failing systems the
RAID10 module is used. The working system has hardware RAID10 and the
Linux RAID10 is not compiled.

I'll try to investigate this way.

Thanks for the heads up.

-- 
Nicolas Sebrecht


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]