[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] portability issue on Centos 6.0



  I just tred compiling 0.9.4 and git head on Centos 6.0, for the
possible libvirt.org server replacement and it fails in both cases
with:

  CC     libvirtd-remote.o
remote.c: In function 'remoteDispatchAuthPolkit':
remote.c:2161: error: invalid initializer

This correspond to the following macro

    PROBE(CLIENT_AUTH_ALLOW, "fd=%d, auth=%d, username=%s",
              virNetServerClientGetFD(client), REMOTE_AUTH_POLKIT,
              ident);

I'm a bit lost how the expansion could lead to this and why, unless the
DTrace support in Centos 6 is slightly different than on RHEL, I will
look but if someone has an idea :-)

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]