[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] Libvirt 0.9.4rc2 + qemu 0.15 VNC/TLS not working



Hi all,
I am trying new versions of software for my libvirt/qemu farm. I upgraded libvirt to 0.9.3 and I had problems with loading certificates for libvirt itself (probably GNUTLS related). Upgrade to 0.9.4rc2 solved the problem. Now I am trying to upgrade qemu (from 0.12.5) to 0.15. I compiled the SRPM from rawhide for Fedora 13 (OS on my farms) and I copied the binary to one farm, so I can choose qemu version by <emulator> element in guest XML. I had problem with booting off virtio disk, but upgrade of seabios to 0.6.2 solved it (I had to make a wrapper for qemu to be able to add -bios option though). But main issue that I am not able to solve is that VNC is not using TLS. I've found out these:
* qemu 0.12.5 is working without problems
* there is no error in libvirt or qemu machine log
* If I copy the command from libvirt log, remove the network and monitor definition and start it under root, TLS works as expected * the vnc definition on command line is quite simple: -vnc 0.0.0.0:0,password,tls,x509=/etc/pki/libvirt/pki-vnc -k en-us

I am thinking whether there is not a problem with monitor setting something after the machine starts. Libvirt does the same with password, so maybe it does something with TLS. Unfortunately I do not know whether there is any option how to debug the monitor libvirt<->qemu communication.

And I have one other question. Is there any way how to interact directly with monitor? Qemu has new guest agent that seems to provide some nice functions and expose them via monitor and I would like to test it.

Radek


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]