[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCHv2 1/5] hyperv: Add configure check for OpenWSMAN



2011/8/20 Eric Blake <eblake redhat com>:
> On 08/03/2011 09:00 AM, Matthias Bolte wrote:
>>
>> ---
>>
>> v2:
>> - relax OpenWSMAN requirement to 2.2.3
>> - move libvirt.spec.in change from 2/5 here and fix OpenWSMAN package name
>> - qoute all PKG_CHECK_MODULES parameters
>>
>>  configure.ac    |   38 ++++++++++++++++++++++++++++++++++++++
>>  libvirt.spec.in |    9 +++++++++
>>  2 files changed, 47 insertions(+), 0 deletions(-)
>
> Finally getting time to look at this series.  I think I already ack'd this
> one, but it still looks good.
>
>> +%if %{with_hyperv}
>> +BuildRequires: libwsman-devel>= 2.2.3
>
> That should allow compilation on Fedora 14, so this time around, I'll be
> compile-testing your series as part of my review (even though, as you
> pointed out, without libwsman 2.2.6 there are some serious bugs that render
> the library harder to use and disable lots of stuff).

Actually, even openwsman 2.2.6 is not good enough. I'm currently have
a bunch of patches pending for review and inclusion into upstream to
fix the problem I came across using openwsman in the driver.

I have a git clone with the patches on it on github, if someone is interested:

https://github.com/photron/openwsman/commits/fixes

-- 
Matthias Bolte
http://photron.blogspot.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]