[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [Qemu-devel] libvirt doesn't work with qemu 1.0



On 12/02/2011 08:21 AM, Gerd Hoffmann wrote:
   Hi,

$subject says all.  The error message is:

error: internal error cannot parse /home/kraxel/bin/qemu-default version
number in 'QEMU emulator version 1.0, Copyright (c) 2003-2008 Fabrice
Bellard'

Parsing help output for the version number is a really bad idea. query-version in QMP does the right thing:

(QEMU) query-version
{u'return': {u'qemu': {u'micro': 0, u'major': 1, u'minor': 0}, u'package': ''}}

This is the supported way of figuring out the version number and it's what libvirt should be using.

Regards,

Anthony Liguori


cheers,
   Gerd

PS: libvirt-0.9.4-23.el6.x86_64



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]