[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [Qemu-devel] libvirt doesn't work with qemu 1.0



On 12/02/2011 09:08 AM, Jiri Denemark wrote:
On Fri, Dec 02, 2011 at 08:50:11 -0600, Anthony Liguori wrote:
On 12/02/2011 08:21 AM, Gerd Hoffmann wrote:
    Hi,

$subject says all.  The error message is:

error: internal error cannot parse /home/kraxel/bin/qemu-default version
number in 'QEMU emulator version 1.0, Copyright (c) 2003-2008 Fabrice
Bellard'

Parsing help output for the version number is a really bad idea.  query-version
in QMP does the right thing:

(QEMU) query-version
{u'return': {u'qemu': {u'micro': 0, u'major': 1, u'minor': 0}, u'package': ''}}

Which of course only works with new enough QEMU that is known to support QMP
(which BTW we detect by checking the version number).

Or you could just try the -qmp option and if QEMU exits, it doesn't support it. That's going to be a lot more reliable than checking a version number.

Regards,

Anthony Liguori

Anyway, the fix is easy,
we just need to assume micro is 0 if it's missing instead of requiring it to
be present. A fix will come soon.

Jirka



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]