[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] build: fix build with older libxml2



On 07.12.2011 23:06, Eric Blake wrote:
> On RHEL 5, with libxml2-2.6.26, the build failed with:
> virsh.c: In function 'vshNodeIsSuperset':
> virsh.c:11951: warning: implicit declaration of function 'xmlChildElementCount'
> 
> (or if warnings aren't errors, a link failure later on).
> 
> * src/util/xml.h (virXMLChildElementCount): New prototype.
> * src/util/xml.c (virXMLChildElementCount): New function.
> * src/libvirt_private.syms (xml.h): Export it.
> * tools/virsh.c (vshNodeIsSuperset): Use it.
> ---
> 
> I haven't decided yet whether this is trivial enough to push under
> the build-breaker rule, but it did fix my build on RHEL 5.
> 
>  src/libvirt_private.syms |    1 +
>  src/util/xml.c           |   20 ++++++++++++++++++++
>  src/util/xml.h           |    1 +
>  tools/virsh.c            |    9 +++++----
>  4 files changed, 27 insertions(+), 4 deletions(-)

ACK

Michal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]