[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] macvtap nt working on kvm



On 12/14/2011 07:40 AM, Amit Tewari wrote:

Hi all,

My test environment

Host os=rhel6.1

Guest os = rhel6.1

Libvirt=0.8.7

Kvm hypervisor

I have made this entry in guest xml file

<interface type='direct'>

<source dev='eth0' mode='bridge'/>

<model type='virtio'/>

<address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>

</interface>

Now when I start the guest

*#virsh start guest*

Following macvtap0 is created on host and is shown below

#*ip link show macvtap0*

51: macvtap0 eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UNKNOWN qlen 500

    link/ether 52:54:00:55:AE:B5brd ff:ff:ff:ff:ff:ff

but when the guest is up and I try to perform

**

*# ifup eth0*

*eth0 has same mac address as that of macvatap0 that is 52:54:00:55:AE:B5*

**

*due to this guest is not able to get dhcp address nor static ip address is working*.



That is not the reason your guest is unable to get an IP address. It is normal behavior for eth0 on the guest to have the same MAC address as the macvtap device on the host.


Please let me know how macvtap work on kvm.


Have you opened a ticket with Red Hat support? I don't recall details, but know that there were at least problems with other modes of macvtap that were not working until 6.2.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]