[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCHv2] build: let autobuild check more code



On Fri, Dec 16, 2011 at 11:39:26AM -0700, Eric Blake wrote:
> On 12/16/2011 02:08 AM, Daniel P. Berrange wrote:
> 
> >> @@ -71,23 +76,7 @@ if [ -x /usr/bin/i686-pc-mingw32-gcc ]; then
> >>      --host=i686-pc-mingw32 \
> >>      --prefix="$AUTOBUILD_INSTALL_ROOT/i686-pc-mingw32/sys-root/mingw" \
> >>      --enable-compile-warnings=error \
> >> -    --without-xen \
> >> -    --without-qemu \
> >> -    --without-openvz \
> >> -    --without-lxc \
> >> -    --without-vbox \
> >> -    --without-xenapi \
> >> -    --without-uml \
> >> -    --without-sasl \
> >> -    --without-avahi \
> >> -    --without-polkit \
> >> -    --without-python \
> 
> > 
> > It turns out we don't disable dtrace correctly on mingw32, if the build
> > host has it present for native. So we either need to fix configure.ac
> > or add --without-dtrace back in.
> 
> It looks like --without-python is also essential, as I'm now getting:
> 
> libtool: compile:  i686-pc-mingw32-gcc -std=gnu99 -DHAVE_CONFIG_H -I.
> -I../../python -I.. -I/usr/include/python2.7 -I/usr/include/python2.7
> -I../../include -I../include -I../python -Wno-redundant-decls -g -O2 -MT
> libvirtmod_la-libvirt-override.lo -MD -MP -MF
> .deps/libvirtmod_la-libvirt-override.Tpo -c
> ../../python/libvirt-override.c  -DDLL_EXPORT -DPIC -o
> .libs/libvirtmod_la-libvirt-override.o
> In file included from /usr/include/python2.7/Python.h:8:0,
>                  from ../../python/libvirt-override.c:19:
> /usr/include/python2.7/pyconfig.h:1:27: fatal error: bits/wordsize.h: No
> such file or directory
> 
> Why is a mingw build trying to include /usr/include/python2.7/Python.h
> instead of the appropriate mingw-specific buildroot?  It seems like our
> python detection in configure.ac is misbehaving during cross-builds.

I took at look at the python code detection & ran away screaming. Until
someone decides to rewrite it to not suck, I've re-added --without-python
to autobuild.sh so we can get working automated builds again.


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]