[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Require avahi as an rpm dependancy



On 2011年12月29日 21:19, Daniel Veillard wrote:
As seen in https://bugzilla.redhat.com/show_bug.cgi?id=746111

If compiled with the daemon and avahi support, then it's better
to require avahi at the rpm level to avoid daemon startup errors.

diff --git a/libvirt.spec.in b/libvirt.spec.in
index 5537c51..dd5e32f 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -272,6 +272,9 @@ Requires: %{name}-client = %{version}-%{release}
  Requires: module-init-tools
  # for /sbin/ip&  /sbin/tc
  Requires: iproute
+%if ! %{with_avahi}

This should be below instead?

if %{with_avahi}

+Requires: avahi
+%endif
  %endif
  %if %{with_network}
  Requires: dnsmasq>= 2.41



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]