[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [libvirt-php] About the inconsistency in libvirt-php

Thanks for your reply Justin.
We should definitely do something with that. I'll work on that after my shift finishes, maybe even tomorrow shift, since I need to concentrate on something else now. However we should document the naming conventions with functionality described. It should be written in some document as well. I'll take care of this.


On 02/21/2011 03:49 PM, Justin Clift wrote:
On 22/02/2011, at 12:32 AM, Michal Novotny wrote:
libvirt_list_defined_domains() - return pointers for inactive domains, also we should consider renaming it to list_inactive_domains()
Ouch, yeah that looks pretty non-optimal.  Probably better to fix it now, rather than leave it completely wrong. :/

But... it'll need some kind of Big Warning about the problem, and the change, on the libvirt-php pages for the next release. (personal opinion)

Probably something like this:

   WARNING: In previous releases of libvirt-php, the function libvirt_list_defined_domains()
            was returning the wrong kind of information.  It *should* have been showing all
            persistent domains, both active and inactive.  However it was instead showing
            just inactive domains.

            This has now been fixed, so all persistent domains are listed.  If your PHP code
            relies on the incorrect behaviour however, you'll need to adjust it.

Maybe with some details about the new libvirt_list_inactive_domains() function too?

Heh, that's just my opinion anyway. :)

Regards and best wishes,

Justin Clift

Michal Novotny<minovotn redhat com>, RHCE
Virtualization Team (xen userspace), Red Hat

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]