[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] build: add dependency on gnutls-utils



* libvirt.spec.in (Requires): Add gnutls-utils, for virt-pki-validate.
Suggested by Daniel P. Berrange.
---

> > -if [ ! -x $CERTOOL ]
> > +if [ ! -x "$CERTOOL" ]
> >  then
> >      echo "Could not locate the certtool program"
> >      echo "make sure the gnutls-utils (or gnutls-bin) package is installed"

> ACK, though we should have an RPM dep on gnutls-utils to make sure
> this is always present !

Like so?

 libvirt.spec.in |    2 ++
 1 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/libvirt.spec.in b/libvirt.spec.in
index a29693a..b5c9fd9 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -418,6 +418,8 @@ Requires: ncurses
 Requires: nc
 # Needed by libvirt-guests init script.
 Requires: gettext
+# Needed by virt-pki-validate script.
+Requires: gnutls-utils
 %if %{with_sasl}
 Requires: cyrus-sasl
 # Not technically required, but makes 'out-of-box' config
-- 
1.7.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]