[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH v2 3/7] qemu: Rename QEMUD_CMD_FLAG_* to QEMU_CAPS_*



On 02/22/2011 09:48 AM, Jiri Denemark wrote:
> The new names comply more with the fact that they are all members of
> enum qemuCapsFlags.
> 
> ---
> Notes:
>     Version 2:
>     - rebased to current master, no additional changes
> 
>  src/qemu/qemu_capabilities.c |  132 +++++-----
>  src/qemu/qemu_capabilities.h |  122 ++++----
>  src/qemu/qemu_command.c      |  248 ++++++++--------
>  src/qemu/qemu_hotplug.c      |   86 +++---
>  src/qemu/qemu_migration.c    |   12 +-
>  src/qemu/qemu_process.c      |   10 +-
>  tests/qemuargv2xmltest.c     |    2 +-
>  tests/qemuhelptest.c         |  656 +++++++++++++++++++++---------------------
>  tests/qemuxml2argvtest.c     |  310 ++++++++++----------
>  9 files changed, 789 insertions(+), 789 deletions(-)

The diffstat agrees that this was completely mechanical, and the
compiler confirms you didn't miss any cases (renames are sometimes quite
easy to verify without re-reading the entire patch :)

> -    QEMUD_CMD_FLAG_CHARDEV_SPICEVMC = (1LL << 56), /* newer -chardev spicevmc */
> -    QEMUD_CMD_FLAG_DEVICE_SPICEVMC = (1LL << 57), /* older -device spicevmc*/
> -    QEMUD_CMD_FLAG_VIRTIO_TX_ALG = (1LL << 58), /* -device virtio-net-pci,tx=string */

> +    QEMU_CAPS_CHARDEV_SPICEVMC = (1LL << 56), /* newer -chardev spicevmc */
> +    QEMU_CAPS_DEVICE_SPICEVMC = (1LL << 57), /* older -device spicevmc*/
> +    QEMU_CAPS_VIRTIO_TX_ALG = (1LL << 58), /* -device virtio-net-pci,tx=string */

And you picked up the VIRTIO_TX_ALG flag added since your v1, so:

ACK.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]