[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Simplify "NWFilterPool" to "NWFilter"



On Sun, Jan 16, 2011 at 12:00:41AM +0100, Matthias Bolte wrote:
> The public object is called NWFilter but the corresponding private
> object is called NWFilterPool. I don't see compelling reasons for this
> Pool suffix. One might argue that an NWFilter is a "pool" of rules, etc.
> 
> Remove the Pool suffix from NWFilterPool. No functional change included.
> ---
>  cfg.mk                                 |    8 +-
>  src/conf/nwfilter_conf.c               |  237 ++++++++++++++++----------------
>  src/conf/nwfilter_conf.h               |   60 ++++----
>  src/datatypes.c                        |   72 +++++-----
>  src/datatypes.h                        |    8 +-
>  src/driver.h                           |    4 +-
>  src/libvirt.c                          |    4 +-
>  src/libvirt_private.syms               |   20 ++--
>  src/nwfilter/nwfilter_driver.c         |  112 ++++++++--------
>  src/nwfilter/nwfilter_gentech_driver.c |   30 ++--
>  10 files changed, 276 insertions(+), 279 deletions(-)


ACK

Daniel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]