[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Installing libvirt 0.8.7 Ubuntu 9.10

Le mardi 18 janvier 2011 12:06:00, Marcela Castro León a écrit :
> Hello:
> I'm installing libvirt 0.8.7 on Ubuntu 9.10 to work at a project at
> Autonomous University.
> But when make ./configure, I've got:
> checking pkg-config is at least version 0.9.0... yes
> checking for XMLRPC... no
> checking for LIBXML... no
> checking libxml2 xml2-config >= 2.6.0 ... configure: error: Could not find
> libxml2 anywhere (see config.log for details).
> But I've libxml2 installed on mu system
> marcela santacruz:~/libvirt/libvirt-0.8.7$ dpkg -l | grep libxml2
> ii  libxml2
> 2.7.5.dfsg-1ubuntu1.2                      GNOME XML library
> ii  libxml2-utils
> 2.7.5.dfsg-1ubuntu1.2                      XML utilities
> ii  python-libxml2
> 2.7.5.dfsg-1ubuntu1.2                      Python bindings for the GNOME
> XML library
> The config.log mention No package 'libxml-2.0', but this libary doesn't
> exit.
> I've attach this log to further information.
> Can you tell me how to follow?
> Thank you.

"libxml2" is a dependency of binary libvirt packages. To be able to build 
libvirt, you have to install development files for that library (libxml2-dev).

I just uploaded libvirt 0.8.7-1 to Debian, since Ubuntu libvirt package are 
merged with Debian libvirt packages I assume it will work fine without changes 
on Ubuntu. Just take a look here:
Only amd64 architecture is available for now, but the other architectures will 
be available in the following hours.

If you really want to build libvirt by hand, you can take a look here and 
check the build dependencies:

Laurent Léonard

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]