[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] FreeBSD Port, update to 0.9.2 compile error



On Mon, Jun 27, 2011 at 09:29:34AM -0700, Jason Helfman wrote:
> Hi,
> On Thu, Jun 09, 2011 at 08:55:01PM +0800, Daniel Veillard thus spake:
> >On Wed, Jun 08, 2011 at 07:44:43AM -0700, Jason Helfman wrote:
> >>> On Tue, Jun 07, 2011 at 11:08:02PM -0700, Jason Helfman wrote:
> >>>> I found the issue in building was an absolute path for apibuild.py for
> >>>> python, that is incorrect on FreeBSD.
> >>>
> >>>  okay, where is it on FreeBSD ?
> >>
> >>/usr/local/bin
> >>
> >>>> Here is a patch:
> >>>>
> >>>> - --- ./docs/apibuild.py.orig	2011-06-07 21:31:43.000000000 -0700
> >>>> +++ ./docs/apibuild.py	2011-06-07 21:31:55.000000000 -0700
> >>>> @@ -1,4 +1,4 @@
> >>>> - -#!/usr/bin/python -u
> >>>> +#!/usr/bin/env python
> >>>
> >>>   I have seens people complaining loudly because env was used like this
> >>> for example:
> >>>
> >>> http://forums.westhost.com/showthread.php?9984-usr-bin-env-python-doesn-t-work
> >>
> >>I would argue that using /usr/bin/env is the correct way to handle this
> >>and users that this breaks for haven't properly configured their
> >>environment path for their binaries. Non-standard paths should be put in a
> >>path so /usr/bin/env will work. /usr/bin and /usr/local/bin are very
> >>standard, in my humble opinion.
> >>
> >
> > yes, I was doing the same, and people complained, left and right :-\
> >
> >>>   another way would be to launch python directly giving the path to the
> >>> python script, this is likely to solve the issue there.
> >
> > That IMHO avoids the problem completely and I doubt anybody would
> >complain we should even be able to detect at configure and take specific
> >paths if people want to use a non-system python binary by extending
> >
> >paphio:~/libvirt -> ./configure --help | grep python
> > --with-python           Build python bindings [default=yes]
> >
> >to take a path
> >
> >Daniel
> >
> 
> I was wondering if this issue was addressed in the upcoming release?

  Oops, no but it should be as simple as the following patch, we should
be able to get this fixed in time !

Daniel

-- 
Daniel Veillard      | libxml Gnome XML XSLT toolkit  http://xmlsoft.org/
daniel veillard com  | Rpmfind RPM search engine http://rpmfind.net/
http://veillard.com/ | virtualization library  http://libvirt.org/
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 689fe32..050ebe1 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -181,7 +181,7 @@ $(python_generated_files): $(srcdir)/apibuild.py \
 		$(srcdir)/../include/libvirt/*.h \
 		$(srcdir)/../src/libvirt.c \
 		$(srcdir)/../src/util/virterror.c
-	$(AM_V_GEN)srcdir=$(srcdir) $(srcdir)/apibuild.py
+	$(AM_V_GEN)srcdir=$(srcdir) $(PYTHON) $(srcdir)/apibuild.py
 
 check-local: all
 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]