[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [virt-tools-list] virt-manager/libvirt backwards compatibility problem?



On 07/27/2011 12:28 PM, Whit Blauvelt wrote:
> Looks like my real problem may be not incorporating a Debian/Ubuntu patch
> before building 0.9.x, since netcat differs:
> 
> https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/517478
> 

Hmm, what was the error message you were getting? We've made efforts at
the libvirt level to have useful error reporting here, so that the cause
of failure is more obvious.

Also, I patched virt-manager a while ago to use a shell script to handle
both RH and debian 'nc' versions. Script is here:

http://git.fedorahosted.org/git?p=virt-manager.git;a=blob;f=src/virtManager/console.py;h=1bdf26b38ba50b95379a664d202af66626436f81;hb=HEAD#l95

Yeah, it's complete and utter crack, but this has been a constant
frustration for users, so maybe worth revisiting at the libvirt level
(and hey, launching nc over ssh is kinda crack to being with :) ).

Even if we solved this in a clean way by providing our own
/usr/libexec/libvirt_nc binary, we'd still probably have to play shell
script games over SSH to handle connecting to older libvirt (or what if
libvirt_nc was installed somewhere other than libexec?)

- Cole



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]