[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Start of freeze for libvirt-0.9.4 and availability of rc1



2011/7/26 Jason Helfman <jhelfman e-e com>:
> On Tue, Jul 26, 2011 at 12:26:20PM -0600, Eric Blake thus spake:
>>
>> On 07/26/2011 12:16 PM, Jason Helfman wrote:
>>>
>>> remote.c: At top level:
>>> remote.c:409: error: negative width in bit-field
>>> '_gl_verify_error_if_negative'
>>> remote.c: In function 'remoteDispatchDomainGetBlockJobInfo':
>>> remote.c:1630: error: 'virDomainBlockJobInfo' undeclared (first use in
>>> this
>>> function)
>>
>> Ah.  You're running into the same problem that has been previously
>> reported of compiling against the stale installed libvirt.h instead of
>> the just-built in-tree libvirt.h.
>>
>> Matthias had started a patch for that, but it never got finished.
>>
>> https://www.redhat.com/archives/libvir-list/2011-May/msg01926.html
>>
>>
> I de-installed the port, and then continued with the make process, and it
> installed just fine.
>
> What is the status of this patch? If this isn't going to make it into the
> release, I can warn users that this port needs to be de-installed prior to
> building the port.

It's fixed in git now

http://libvirt.org/git/?p=libvirt.git;a=commit;h=b590866bdb0aea20eda5b96883b8744fedbba88d

But it missed 0.9.4 RC2, so depending on how Daniel plans to do the
release of 0.9.4 it might not be included.

-- 
Matthias Bolte
http://photron.blogspot.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]