[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH] Fix netdev detection on RHEL6x versions of qemu



On Thu, Jun 02, 2011 at 10:04:44AM +0100, Neil Wilson wrote:
> On Wed, 2011-06-01 at 13:38 -0600, Eric Blake wrote:
> 
> > Meanwhile, as to your question about the libvirt testsuit including RHEL
> > qemu -help output: that merely proves that libvirt is properly parsing
> > the available -help output, and not that libvirt is inferring any
> > special properties of RHEL qemu that were not directly advertised in -help.
> > 
> 
> I appreciate your input but I feel that it suffers from the same problem
> you complain of.
> 
> Libvirt is not properly parsing the help message as the decisions it
> makes means that the attach-device derived functions do not work with
> the qemu supplied on a major platform.
> 
> The actual fault is with 12.x standard qemu advertising netdev when it
> doesn't have it. Libvirt is using  'special properties not directly
> advertised in -help' to infer that 12.x netdev is broken.

12.x does have netdev, but we don't want to use it because it does
not support hotplug, only with initial startup. Hence it is better
to continue using the old network syntax to avoid loosing functionality

Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]