[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] Building on Solaris 11 Express



On Fri, Jun 3, 2011 at 21:07, Matthias Bolte
<matthias bolte googlemail com> wrote:
> 2011/6/3 Richard Laager <rlaager wiktel com>:
>> On Fri, 2011-06-03 at 09:11 +0200, Matthias Bolte wrote:
>>> > It has probably something to do with this piece of code, in daemon/libvirtd.c:
>>
>> I finally got back to looking at this, and that's what I discovered as
>> well. (I hadn't checked my email in the interim.)
>>
>> I stopped it from dropping privileges and now libvirtd starts. Earlier,
>> when launching virsh (with no arguments), I think I got some errors
>> about localhost:8000.
>>
>> I ignored that, as I'm really looking to test VirtualBox, which brings
>> me to this...
>>
>> If I don't have the VirtualBox GUI running, virsh fails to connect:
>>
>> /usr/local/bin/virsh -c vbox:///session
>> ... hangs for 10 or so seconds ...
>> error: internal error nsIEventQueue object is null
>> error: failed to connect to the hypervisor
>
> This is typically a sign of a COM object ID mismatch between
> VirtualBox and libvirt. What versions of libvirt and VirtualBox are
> you running? By any chance are you running a beta or release candidate
> of VirtualBox?

libvirt-0.9.2-rc2, and VirtualBox-4.0.8-SunOS-r71778.pkg from www.virtualbox.org

This exact same combination works fine on OSX.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]