[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] does libvirt get disk->info.alias, when attaching a disk by virDomainAttachDevice?



On 06/09/2011 01:26 PM, 李敬伟 wrote:
> Hi,
> 
> I am using libvirt 0.9.1 on CentOS 5.5 64bit ,
> 
> Created a vm :virsh create libvirt.xml
> 
> Attached a disk ,virsh attach-disk 3 /opt/vms/test.img vdb
> 
> When getting blosk stats ,virsh domblkstats 3 vdb ,it showed
> 
> error: Failed to get block stats 3 vdb
> 
> error: internal error missing disk device alias name for vdb
> 
> while virsh domblkstat 3 vda, it showed
> 
> vda rd_req 6667
> 
> vda rd_bytes 154084864
> 
> vda wr_req 9530
> 
> vda wr_bytes 57196544
> 
> I guess libvirt does not get disk->info.alias when attaching a disk,so 
> it can not get block status.
> 
> # virsh version
> 
> Compiled against library: libvir 0.9.1
> 
> Using library: libvir 0.9.1
> 
> Using API: QEMU 0.9.1
> 
> Running hypervisor: QEMU 0.9.1
> 
> # rpm -qa|grep kvm
> 
> kmod-kvm-83-224.el5.centos.1
> 
> kvm-qemu-img-83-224.el5.centos.1
> 
> etherboot-zroms-kvm-5.4.4-13.el5.centos
> 
> kvm-83-224.el5.centos.1
> 
> Jingwei Li (lijingwei9060 gmail com <mailto:lijingwei9060 gmail com> or 
> lijw bingosoft net <mailto:lijw bingosoft net>)

Saw you filed but against libvirt:
https://bugzilla.redhat.com/show_bug.cgi?id=711971

Please see the comment I added

Regards
Osier


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]