[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH v2] Fix autostart flag when loading running domains



On 06/12/2011 09:05 PM, Michael Chapman wrote:
> Drivers load running persistent and transient domain configs before
> inactive persistent domain configs, however only the latter would set a
> domain's autostart flag. This mismatch between the loaded and on-disk
> state could later cause problems with "virsh autostart":
> 
>   # virsh autostart example
>   error: Failed to mark domain example as autostarted
>   error: Failed to create symlink '/etc/libvirt/qemu/autostart/example.xml to '/etc/libvirt/qemu/example.xml': File exists
> 
> This patch ensures the autostart flag is set correctly even when the
> domain is already defined.
> 
> Fixes:
> 
>   https://bugzilla.redhat.com/show_bug.cgi?id=632100
>   https://bugzilla.redhat.com/show_bug.cgi?id=675319
> 
> v1 -> v2:
>   - free autostartLink
>   - fixed comment
> 
> Signed-off-by: Michael Chapman <mike very puzzling org>
> ---
>  src/conf/domain_conf.c |   19 +++++++++++--------
>  1 files changed, 11 insertions(+), 8 deletions(-)

ACK and pushed.  I added you to AUTHORS, let me know if I need to adjust
spellings.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]