[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[libvirt] [PATCH] build: require newer netcf when it is available



When building for newer Fedora or RHEL, take advantage of the
newer netcf packaging to guarantee interface snapshot support.

* libvirt.spec.in (BuildRequires): Bump minimum version on
platforms that support netcf 0.1.8.
---

I don't think we need an explicit 'Requires: netcf-libs >= 0.1.8' line
for the runtime dependency, since netcf uses versioned symbols.

I'm not sure whether F16 was the right target for requiring 0.1.8,
or whether we should also try to include F15 (but 0.1.8 has not yet
been built for F15).

 libvirt.spec.in |    4 ++++
 1 files changed, 4 insertions(+), 0 deletions(-)

diff --git a/libvirt.spec.in b/libvirt.spec.in
index 75b145a..11b8591 100644
--- a/libvirt.spec.in
+++ b/libvirt.spec.in
@@ -424,8 +424,12 @@ BuildRequires: libcap-ng-devel >= 0.5.0
 BuildRequires: libssh2-devel
 %endif
 %if %{with_netcf}
+%if 0%{?fedora} >= 16 || 0%{?rhel} >= 6
+BuildRequires: netcf-devel >= 0.1.8
+%else
 BuildRequires: netcf-devel >= 0.1.4
 %endif
+%endif
 %if %{with_esx}
 %if 0%{?fedora} >= 9 || 0%{?rhel} >= 6
 BuildRequires: libcurl-devel
-- 
1.7.4.4


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]