[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] qemu error: "fsdev is not supported by this qemu build."



On Wed, Jun 22, 2011 at 12:27:50PM +0100, Daniel P. Berrange wrote:
> On Wed, Jun 22, 2011 at 11:43:48AM +0100, Richard W.M. Jones wrote:
> > When trying to add a 9p filesystem to a guest, I get the qemu error
> > "fsdev is not supported by this qemu build." (when starting the
> > guest).
> > 
> > I'm still looking at this.  It seems to be something to do with the
> > machine type causing the -fsdev option not to be registered inside
> > qemu.  I just wanted to record the problem here in case anyone else
> > has any ideas.
> > 
> > Full XML and qemu command line is below.
> 
> This is all fine & practically identical to what I've used
> 
> > Occurs with:
> > 
> > libvirt-0.9.2-2.fc16.x86_64
> > 2:qemu-system-x86-0.14.0-8.fc16.x86_64
> 
> I have qemu-0.14.0-0.1.201102107aa8c46.fc15.x86_64  which I
> built myself. IIUC the code, the only way you can lack the
> fsdev support is if libattr.so was not present during the
> build. So perhaps  the Fedora QEMU RPM is missing a
> BuildRequires: libattr-devel, and I just happened to have
> that available on the machine I did my build on.

Yep, that's the problem. Looking in

  http://kojipkgs.fedoraproject.org/packages/qemu/0.14.0/8.fc16/data/logs/x86_64/build.log

I see the configure summary:

  ATTR/XATTR support no


Daniel
-- 
|: http://berrange.com      -o-    http://www.flickr.com/photos/dberrange/ :|
|: http://libvirt.org              -o-             http://virt-manager.org :|
|: http://autobuild.org       -o-         http://search.cpan.org/~danberr/ :|
|: http://entangle-photo.org       -o-       http://live.gnome.org/gtk-vnc :|


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]