[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 1/2] set HAVE_LIBNL in config.h



2011/6/23 Stefan Berger <stefanb linux vnet ibm com>:
> Set HAVE_LIBNL to be able to conditionally compile libnl code.
>
> Signed-off-by: Stefan Berger <stefanb linux vnet ibm com>
>
> ---
>  configure.ac |    3 +++
>  1 file changed, 3 insertions(+)
>
> Index: libvirt-acl/configure.ac
> ===================================================================
> --- libvirt-acl.orig/configure.ac
> +++ libvirt-acl/configure.ac
> @@ -2377,7 +2377,10 @@ if test "$with_macvtap" = "yes"; then
>     ], [
>         AC_MSG_ERROR([libnl-devel >= $LIBNL_REQUIRED is required for macvtap support])
>     ])
> +    have_libnl=yes
> +    AC_DEFINE_UNQUOTED([HAVE_LIBNL], 1, [whether the netlink library is available])
>  fi
> +AM_CONDITIONAL([HAVE_LIBNL], [test "$have_libnl" = "yes"])
>
>  AC_SUBST([LIBNL_CFLAGS])
>  AC_SUBST([LIBNL_LIBS])
>
>

HAVE_LIBNL is just an alias for WITH_MACVTAP by this construct. So you
could just use WITH_MACVTAP in the code instead of HAVE_LIBNL. Or do
you plan to use libnl also for non-macvtap related code.

-- 
Matthias Bolte
http://photron.blogspot.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]