[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] [PATCH 3/1] build: avoid python 2.4 build failure



On 06/24/2011 02:58 AM, Daniel Veillard wrote:
> On Thu, Jun 23, 2011 at 10:26:03PM -0600, Eric Blake wrote:
>> I'm not sure when Py_ssize_t was introduced; but Fedora 14 Python 2.7
>> has it, while RHEL 5 Python 2.4 lacks it.
>>
>> * python/typewrappers.h (Py_ssize_t): Define for older python.
>> ---

>> +/* Work around really old python.  */
>> +#if PY_MAJOR_VERSION == 2 && PY_MINOR_VERSION < 7
>> +typedef ssize_t Py_ssize_t;
>> +#endif
>> +
>>  #define PyvirConnect_Get(v) (((v) == Py_None) ? NULL : \
>>          (((PyvirConnect_Object *)(v))->obj))
>>
> 
>   I think the workaround is fine, if we ever hit a protability problem
> due to this then we can refine, but that looks simple enough for me and
> does the job
> 
>  ACK,

Thanks; pushed.

-- 
Eric Blake   eblake redhat com    +1-801-349-2682
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]