[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [libvirt] problem attaching/detaching disk



At 03/04/2011 12:34 AM, Shi Jin Write:
> Hi Wen,
> 
> Thank you very much.
> Here are my versoins:
> [cloudadmin test2 ~]$ virsh version
> Compiled against library: libvir 0.8.1
> Using library: libvir 0.8.1
> Using API: QEMU 0.8.1
> Running hypervisor: QEMU 0.12.1
> 

I use the same version of libvirt, and still can not reproduce this bug.

> [cloudadmin test2 ~]$ cat /etc/redhat-release 
> Red Hat Enterprise Linux Server release 6.0 (Santiago)
> [cloudadmin test2 ~]$ uname -a
> Linux test2 2.6.32-71.el6.x86_64 #1 SMP Wed Sep 1 01:33:01 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
> 
> 
> Could you please post the "virsh dumpxml" result of the VM after the vdb is attached?

    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2' cache='none'/>
      <source file='/var/lib/libvirt/images/rhel6rc_64.img'/>
      <target dev='hda' bus='ide'/>
      <alias name='ide0-0-0'/>
      <address type='drive' controller='0' bus='0' unit='0'/>
    </disk>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/var/lib/libvirt/images/test.iso'/>
      <target dev='hdc' bus='ide'/>
      <readonly/>
      <alias name='ide0-1-0'/>
      <address type='drive' controller='0' bus='1' unit='0'/>
    </disk>
    <disk type='file' device='disk'>
      <driver name='file' type='qcow2'/>
      <source file='/var/lib/libvirt/images/test3.img'/>
      <target dev='vdb' bus='virtio'/>
      <alias name='virtio-disk1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>
    </disk>
    <controller type='ide' index='0'>
      <alias name='ide0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    </controller>


> 
> Thanks in advance.
> 
> Shi
>>
>> I try to reproduce this bug with upstream libvirt and qemu,
>> but it works fine to me:
>>
>> # virsh attach-disk RHEL6RC
>> /var/lib/libvirt/images/test3.img vdb  --driver file
>> --subdriver qcow2
>> Disk attached successfully
>>
>> # virsh detach-disk RHEL6RC vdb
>> Disk detached successfully
>>
>> What is version of libvirt and qemu that you use?
>>
>>> But if I tried to remove the vda which uses qemu as
>> driver name it would work.
>>> [cloudadmin test2 ~]$ virsh detach-disk one-52 vda
>>> Disk detached successfully
>>>
>>> I also tried with raw disks to attach/detach and saw
>> the same problems.
>>>
>>> Thank you very much.
>>> Shi
>>>
>>>
>>> [1]: http://www.redhat.com/archives/libvir-list/2010-August/msg00449.html
>>>   
>>> --
>>> Shi Jin, PhD
>>>
>>>
>>>        
>>>
>>> --
>>> libvir-list mailing list
>>> libvir-list redhat com
>>> https://www.redhat.com/mailman/listinfo/libvir-list
>>>
>>
>>
> 
> 
>       
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]